Web-4MTM Reference Manual
  Mail
Contents
Starting Mail  Quitting Mail  Reading Mail  Sending Mail  
Composing Mail  Viewing Attachments  Mail Folders  Using Groups  
Deleting Mail  Saving Mail  Sorting Mail  Searching Mail  Forwarding Mail  Auto-Forwarding Mail  Replying to Mail
External Mail  Checking for New Mail  Mail Check Interval
Re-Synchronizing Mail

Web-4M Email ensures that every one of your users has access to Email for sending text, graphics and other MIME mail. It is integrated with the Web-4M user lists and groups and documents and works with Web-4M News Groups and with external mailers. Mail can be sent to users in the Web-4M system or to any address on the Internet via an SMTP server. You can also use the mailer to retrieve mail from a POP3 mail server. The electronic mail window is similar to the news group window

Starting Email

Email is started by pushing the [Mail ] button on the control panel

Quitting Email

You may quit the Mailer by selecting [Quit] from the File menu or from the buttons  in the Mailer. 

Reading Email

In order to read an Email message, select [ the mail message you wish to read] from the list shown at the top of the mailer by clicking (either a single or double click will work) on the mail message. This will display the mail message and show you a list of attachments to the message. Alternatively you may select the [ Next] button to read the list of e-mail messages one at a time.

The Web-4M reader uses the letters N,R, and X in front of the E-Mail messages to indicate their current status.  The "N" means that the message is new to both the external mail server, and to Web-4M.  The "R" appears when the message has been read on the external mail server, but not on Web-4M, and the "X" means that the message has been deleted on the external server, but not on your Web-4M account.  If a message appears with an "X" beside it, and you do not have this message on another server, or saved, it may be your only copy.

Sending Email

You may send an Email message by selecting [ Compose], [Forward] or [ Reply]  from the Message menu or from the buttons on the mailer. These actions allow you to create a new mail message, edit and forward the currently selected mail message or reply to the current mail message, respectively. Selecting any of the actions activates the message composition window to enable you to create the desired message. Once you have composed the message and added any attachments you can send it by selecting send on the compose window. 

The register and log functions will notify you when the recipient has opened the e-mail message and will keep track of track of the message you have sent to others. Logged mail is automatically saved in your SentMail folder. 

Composing Email

Composing Email generally requires several actions: you must specify the recipient(s), you may create a subject for the mail of the mail message, you may enter the text for the main body of the mail message and you may add attachments to the mail. These are all completed using the mail composer and may be completed in any order. 

 To specify the recipient(s) of the message you enter their address(es) in the "To:" text entry box in the top section of the composer  (separated by a comma if more than one).  Each addresses may be the username of another user in the system, the name of a group, or an external Email addresses ( such as goodperson@earth.planet.org ). The lists on the top right of the mail composer show you all the users of the system and all of your previously defined groups. Selecting either a user name or a group adds it to the list of recipients. You may also elect to send the message to every user in the system by selecting the "everyone" group. To enter a subject, fill in the "Subject:" text entry box as desired. The "CC:" box allows you to copy the message to yourself or others. The user and groups lists function with the CC box also. When you activate the composer using "Reply" the recipient and subject will be filled when the composer is activated. 

 The body of the text is entered in the large text entry box in middle of the compose area. 

To add attachments, select the [Add Attachments ] button on the left side of the compose window, above the attachment display area. This will activate a document selector you may use to select one or more documents to attach to the mail message. 
In principle you may add any file as an attachment, however, only those files for which the recipient has the required software can be used by your recipient. Commonly used file types include text, html, gif, and jpg files. Users of Web-4M can also deal properly with calendar events, whiteboard files, and groups. 

Once you have completed your email message select [ Send] to send the message or select [Quit ] to abort the message. 

Viewing Mail Attachments

Attachments sent with Email may be viewed with the mail reader. Icons will be displayed in the attachment display area on the lower left portion of the mail window. Selecting an attachment by pushing on its icon will view the selected attachment. Pushing the  [ Attachments] button at the top of the attachment area will show all of the attachments. There are many types of attachments that can be sent with an e-mail message. Pictures sent in the form of gif's or jpg's will be shown in an image window and may be displayed in the whiteboard, saved to disk or discarded. Whiteboards will be displayed in the whiteboard. Calendar events may be added to your calendar or ignored. Groups may be added to your own list of groups. HTML file attachments may be opened in the browser, saved to disk, or discarded. HTML references in the text of the mail message will be displayed as an icon in the attachment window and will appear in the browser when selected. Most other attachments will be launched, saved or discarded.  Launching will work for the most common office software file types, if your computer has the necessary software. Those attachments that Web-4M is unable to display automatically may be saved to your disk for processing later. 

Using Mail Folders

Web-4M allows you to store mail you receive in mail folders. This has the advantage that you can save mail messages in folders and not have to sort through all of your mail messages every time you wish to read your mail. The Web-4M mail reader is initially configured with four mail folders, Inbox, DeletedMail, SavedMail and SentMail. New mail appears in the Inbox, deleted mail is moved to the DeletedMail folder, and logged mail is copied to the SentMail folder.  The SavedMail folder can be used for saving messages for later viewing and/or reply. 

Mail messages may be moved to a folder by either dragging them or by using the Move button. More than one message may be moved at one time by selecting additional messages (in addition to the one being viewed).  To do this hold down the control key and select the messages on at a time, or hold down the shift key and select a block of messages. 

To drag the selected mail messages into a folder simply click on any of the selected messages and drag the mouse to the desired destination folder. As you drag a small icon will appear with a number in it which tells how many messages are being dragged. Release the mouse when you are pointing to the desired destination folder (it will turn red). This will move the messages to the destination folder, update the folder lists and return you to your starting folder. An alternative way to move the selected mail messages is to push the [Move to Folder] button and then select [the destination folder] in the folder list. If you wish to cancel the move, push the [ Cancel Move] button rather then selecting a destination folder. 

New folders and subfolders within folders may be created, emptied, and deleted using the options under the Folders menu. 

Selecting the  [Folders]  menu, followed by [Add Folder] will activate a text entry box in which you may enter the name of the folder or subfolder you wish to add. 

If you wish to delete a folder, first select the [folder ]. Then selecting the [Folders] menu, followed by [Delete Folder] will activate a text entry box in which you may enter the name of the folder or subfolder you wish to delete. Since the name of the selected folder is already in the text box, pressing return will delete that folder. 

 To remove all the mail from a specific folder, select [ the folder you wish to empty]. Then selecting the [ Folders] menu, followed by [Emtpy Folder ] will activate a text entry box in which you may enter the name of the folder or subfolder you wish to empty. Since the name of the selected folder is already in the text box, pressing return will empty that folder. 

Any mail deleted using the [Delete] button on the mail reader is moved to the DeletedMail folder. This deleted mail will remain in this folder until you remove it using the Empty Deleted Mail option under the Folder menu. To do this select the [ Folders] menu  followed by [Emtpy Deleted Mail].

Using Groups in Mail

Groups are very useful, especially for saving lists of  users to whom you commonly send mail or to shorten a long mail address to something easier to remember. Each time you start to compose a mail message you will see a list of your groups on the right hand side of the composer. Selecting one of these groups will add it to the list in the "To:" text entry area and send the email message to everyone in the  group. To create or modify a group, select the [Tools] menu, followed by [Edit Groups]. This will activate the group editor which can be used to edit or create groups. 

 To create a group, enter the new group name in the group text entry area below the Groups list. Then push the [ Create New Group] button. There are three ways to add users to the group. First, you may select [users] and [groups] from the All Users and All Groups lists on the right and then push the [Add All Selected to Group] button below the All Users list. You may also drag the selected users or groups over into the Group Members list. Alternatively, you may enter a username or an external E-mail address in the text entry area below the Group Members list and then push the [Add Name to Group] button. When you are satisfied with your group definition be sure to Save the group by selecting [Save and Exit ] from the buttons at the bottom or under the File menu. 

 To delete a group, select [the group to delete] from the Groups  list, then select the [ Group]  menu, followed by [Delete Selected Group]

 You may also delete users from an existing alias by selecting [ the alias] and [the user] to be deleted . Then select the [Group]  menu , followed by [Delete Selected User]. Finally, be sure to save the edited group. 

Deleting Mail Messages and Folders

Mail messages may be deleted by selecting [the message] and then pushing the [Delete] button on the mail reader. Any mail deleted using the [ Delete] button on the mail reader will be moved to the DeletedMail folder. This deleted mail will remain in this folder until you remove it using the Empty Deleted Mail option under Folder. To do this select the [ Folders] menu, followed by [Empty Deleted Mail].  This will permanently remove these mail messages from the system. 

To remove all the mail from a specific folder, [ select the folder you wish to empty]. Then selecting [ Folders] from the menu at the top of the mail reader, followed by [Emtpy Folder] will activate a text entry box in which you may enter the name of the folder or subfolder you wish to empty. 

If you wish to delete a folder, select the [folder ]. Then selecting [Folders] from the menu at the top of the mail reader, followed by [ Delete Folder] will activate a text entry box in which you may enter the name of the folder or subfolder you wish to delete. Since the name of the selected folder is already in the text box, pressing return will delete that folder. 

Saving Mail

To save a mail message to the disk select [the message to be saved], then select the [File ]  menu at the top of the mail reader, followed by [ Save Message] or [Save Message body]. Saving the message saves both the header information and the main text of the mail message. Saving the message body saves only the main text. 

Sorting Mail

There are many way to sort your mail, which affects the order in which mail appears in the Mail Files list. Mail may be sorted by time, sender, unread, and subject. If mail is being sorted by sender, unread or subject you may control the order in which messages from the same sender, unread messages, or those with the same subject appear - oldest first or newest first.  To select the sort field simply click in the header area of the desired column in the Mail Files list. Clicking a second time on the same header will reverse the order of the sort. You may also choose the sort field by selecting the  [Sort]  menu and then choosing [the desired sort option] from the pull down menu. 

A checkbox in the Sort menu controls the order in which the mail messages from the same sender, unread messages, or those with the same subject appear - oldest first or newest first. 

Searching

You may search for a string in the headers of the mail messages currently displayed in the Mail Files list. Select the [Tools ] menu, followed by [Find in Headers]. A dialog box will appear allowing you to enter the string of text you wish to search for. Enter the string, then press the [ Search] button or type Return or Enter. The first message header containing the string will be highlighted, and the message displayed. To search for the next occurrence of the same string select [ Find Again] under the Tools menu. 

Printing Mail

To print a message, select the [message to print ] and then select [Print] from either the buttons or under the file menu.  You may print just the message body by selecting the [File] menu and then choosing [Print Message Body]. 

Forwarding Mail

To forward a message, select the [message to forward] and then select [Forward] from either the buttons or under the Message menu. This will activate the mail composer window and include the selected mail message in it for forwarding to another user. You may then edit the mail message before sending it. 

Auto-Forwarding

If you elect not to use the Web-4M  mail tool, you can auto-forward your mail to and external SMTP server. To do this, select [ Setup Auto-Forwarding] under the [Settings ] menu and fill in the external email address and SMTP server. Be aware that attachments in internal Web-4M formats (i.e. White Boards, Slide Shows, Groups...) cannot be viewed outside the Web-4M system.

Replying to Mail

To reply a message, select the [message to which you are replying] and then select [Reply ] from either the buttons or under the message menu. This will activate the mail composer window, and include the original message if you selected that option (see below). Consequently you may edit the mail message before sending it. 

Note that in the message menu you may select different options for replying, while the reply button will use whichever option was last used. These options include replying to the sender, replying to the sender with the original message included, replying to everyone or replying to everyone with the original message included. 

Sending and Receiving External Mail

External Mail Setup Window

Web-4M can send and receive external mail.  Sending and receiving external mail requires that you specify the SMTP and POP3 mail server that you use to handle your external mail. To do this select the  [ Settings] menu, followed by [Setup External Mail]. This will activate the External Mail Setup window in which you need to enter your POP3 server, your username, your password (twice for verification), your return Email address and your SMTP server. If you don't know what these are, ask your system manager or internet service provider for more details. 

Checking for New Mail

Web-4M will automatically notify you of new mail sent by other users of the system. 

If you are using a multi-server Web-4M installation or an external server to retrieve Internet mail, you may check for new mail by selecting the [ File] menu, then selecting [CheckMail].  In order to do this automatically you must set the Mail Check Interval

Mail Checking Interval

When you accept mail from an external mailer, you should set a time interval that Web-4M will use to scan your external mailer for new mail. To set this interval select the [Settings] menu, followed by [Set Mail Check Interval]. This will activate a text entry box in which you enter the number of whole minutes to wait between checks of the external server. Setting this to a small interval checks your mail frequently, but may use your network and computer resources too heavily. Setting this to a long interval may mean that you have to wait a long time to be notified of any new mail. You need to find a medium that works best for you. The Web-4M default value for this interval is 20 minutes. 

Re-Synchronizing External Mail

Web-4M maintains "Inbox Coherency." This means that mail is not deleted from the POP server until you delete it or move it from the Inbox to another folder. Occasionally an external mailer and the Web-4M mailer may miscommunicate. To resolve this problem select the  [Settings ] menu, followed by [Re-Synchronize External Mail]. This will assure Inbox Coherency. After doing this you may see duplicate copies of some of your mail in the Inbox. This is normal, and you may delete the extra copies. 
 


Trademarks Copyright JDH Technologies LLC, 1997-2003. All Rights Reserved.